CanaDream v2.8 for ATS 1.33

CanaDream v2.8 for ATS 1.33
Minimum is REQUIRED for playing or game crash Coast to Coast map 2.6.2.2

Priority:
1-CanaDream 2.8
2-Coast to Coast 2.6.2.2

2.8
compatible ATS 1.33
compatible C2C 2.6.2.2

Credits: ManiaX, Update ShirBlackspots

DOWNLOAD

Leave a Reply

This site uses Akismet to reduce spam. Learn how your comment data is processed.