Download!Cheap American Truck Simulator. Download now!

International 9900i

This is a fix for the International 9900i, so this works with version 1.30+. There is no need to download the old mod, just pop this in the mod folder and your good to go. Add Seeker on steam if you have an old mod that you want to work with the new versions on ATS.
WARNING: DO NOT PUT THIS WITH NEW TRUCK MOD, OR THE GAME WILL CRASH!

Credits: Superman, evh5150vanhalen, Danclark, Kapitan Kriechbaumand others Seeker for fixing it

DOWNLOAD

Leave a Reply

This site uses Akismet to reduce spam. Learn how your comment data is processed.